1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need Help With a Script

Discussion in 'Alibre Script' started by RocketNut, Jun 17, 2019.

  1. idslk

    idslk Alibre Super User

    Hello RocketNut,

    after using the described boolean subtract, you have to hide the source geometries (the disk and the tools)

    upload_2019-6-19_18-24-30.png

    upload_2019-6-19_18-25-14.png

    if you don't do this, you get the closed tools....

    after hiding the source geometries it should look like the following pictures

    the first side:
    upload_2019-6-19_18-27-21.png

    the other side
    upload_2019-6-19_18-28-34.png

    additional shelling is not neccesary.

    Regards
    Stefan
     
  2. RocketNut

    RocketNut Alibre Super User

    OK, I am feeling very stupid here.

    I do not see the AssmBool funtion in the package file!!! I have never used this function, so how do I do this AssmBool funtion?
     

    Attached Files:

    Last edited: Jun 19, 2019
  3. RocketNut

    RocketNut Alibre Super User

    I have tried to use the AssmBool funtion but did not get the same results as you do.

    Complete disk.jpg

    What am I doing wrong?
     
  4. idslk

    idslk Alibre Super User

    Hello RocketNut,

    as i do not know what you have done, it will help if you describe or post a picture how you did you do the AssemblyBoolean.
    What i did, i had shown in picture of a post before . Here i've added some red lines...:
    upload_2019-6-20_9-41-15.png
    In Blanks you have to put your "raw material" ( join all blanks if you have more part than just one can be used...)
    In Tools you have to put your "tools" (one or more parts...)
    The checkmark in Insert results into current assembly creates a file with the source parts and the result part, If unchecked you will get only the result part in a seperate file. (which should be the prefered use).
    This result file could be saved a used as a part in your assembly and gives you a maybe clearer solution in relation to boms and things like this.
    upload_2019-6-20_11-20-18.png
    In dependence of your computer power the Boolean takes some time...

    Regards
    Stefan
     
    Last edited: Jun 20, 2019
  5. RocketNut

    RocketNut Alibre Super User

    Bingo :))))))

    Got it. I do not know why could not get it before. Possible I did not know how to use the AssmBool function properly.


    My Complete_Disk.jpg

    t loads up a lot faster then the part using the booleasnsub function. Along with a very small file.

    Thanks for your help
     
    Last edited: Jun 20, 2019
  6. RocketNut

    RocketNut Alibre Super User

    Ultimaker Cura Sliced.jpg View attachment 27764 OK

    When I tried to print up a test model the slicer does not see the holes!!!! I have tried 5 times with the same results.

    Does any one have a clue what I am doing wrong?
     
    Last edited: Jun 20, 2019
  7. DavidJ

    DavidJ Alibre Super User

    You may have the STL export settings set so that small features get missed. Always review your STL in a viewer of some sort to check if it is 'plausible' before wasting time with the slicer.

    Others more knowledgeable than I about the slicer may point out if it's possible to mess things up with slicer settings.
     
  8. RocketNut

    RocketNut Alibre Super User

    I am use the STL defults settings.

    It's just strange that this is the only part that I have slided that has cameup wrong!! Ultimaker Cura Sliced 2.jpg
     
  9. idslk

    idslk Alibre Super User

    Hello RocketNut,

    as far as your part has a outer diameter of 1500mm i can imagine you have scaled it down to get it printed.
    If you've scaled it, is it possible that there maybe something went wrong?

    Regards
    Stefan
     
  10. RocketNut

    RocketNut Alibre Super User

    I hope someone can come up a suggest why this happening.

    Here is a pic of what it should look like. This was done using the boolean subtract function. Boolean Holes.jpg

    Yes I scale both down to 15%. Along with all the other settings are the same, but very different results.
     
  11. idslk

    idslk Alibre Super User

    The picture you've posted:
    . upload_2019-6-20_20-21-3.png

    shows the result after scaling in AlibreDesign?

    How big is your
    a) *.sat file
    b) *.stl file

    are you able to post them? (or dropbox)

    Do you have another program to watch the files in?

    Regards
    Stefan
     
  12. RocketNut

    RocketNut Alibre Super User

    BTW

    I guess I do not need a script to draw up this part..

    A big thanks to idslk for the great help, alone teaching me some new tricks in drawing upo complex mdels like this.
     
    Last edited: Jun 20, 2019
  13. idslk

    idslk Alibre Super User

    Hello RocketNut,

    I've scaled the result file in AlibreDesign down to 15% and exported it with your settings as an *.STL file.
    I opened the STL-result in a different CAD program just for "verification":
    upload_2019-6-20_21-7-14.png

    Outer Diameter: 225mm
    Diameter of holes: round about 6.4mm
    *.STL file size round about 64MB
    So AlibreDesign seems to produce a correct file for me.

    May it's your slicer/slicer settings.
    Which Slicer do you use?

    Regards
    Stefan
     
  14. RocketNut

    RocketNut Alibre Super User

    I am using CURA to do the slicing and to scale it down to fit. The file size is just under 277Meg bits.

    Ultimaker Cura Sliced.jpg


    For me, it's just strange that this is the only model that did not slice properly.

    May be I should contact CURA support about this problem.
     
    Last edited: Jun 21, 2019
  15. idslk

    idslk Alibre Super User

    as far as the cad-work seems to be ok and i don't have a slicer installed here, i can't give you more help, so the cura support is a good idea.
    Good luck and you may can keep us up to date...

    Regards
    Stefan
     
  16. ajayre

    ajayre Alibre Super User

    For FDM 3D printing there is a minimum X/Y resolution, usually 0.5mm in each direction. Perhaps you are running into that limitation?

    Andy
     
  17. RocketNut

    RocketNut Alibre Super User

    I just got this from Cura support:::

    ================================
    ================================
    Because RocketNut's screenshot didn't work (e-mail attachments to replies to Github don't automatically get posted), here's a screenshot of X-Ray View of your model in Cura:
    [​IMG]

    Initially it showed nothing special but rotating the camera towards the side reveals a bunch of red areas.

    I never used this features so I do not understand what it is telling me.

    X-Ray View will show the insides of your model. If there is extra geometry inside, or the walls are not watertight, then it will show red areas. This means that it is ambiguous what the inside of your model is.

    Since your model has this extra geometry or missing geometry inside (depending how you look at it), it is ambiguous where the insides of your mesh are going to be. This is why Cura can't figure out what spaces to fill with skin, and why this specific model prints so strangely.

    It is not something that we can really fix in Cura realistically. There are tools out there to repair your mesh that go by heuristics, like that the surface that has the fewest sharp corners is the one that you probably intended as the outside of your model. Some suggestions:

    • FreeCAD (like SmartAvionics suggested)
    • MeshLab
    • Blender
    • Netfabb
    All of these work with heuristics, some better than others. I'd advise you to stay away from the voxel-based ones though, like MakePrintable. They tend to make your print very blocky which is disturbing when actually printed.

    I'm closing it because it's not something we can realistically fix.


    =================================================
    =================================================


    So it appears the AssmBoolen function is leaving excess material, which is confusing the slicer.
    I have forward this response to support also.
    Thanks for the great help
     
  18. DavidJ

    DavidJ Alibre Super User

    Have you looked at the stl file in another application, to verify if the issue exists before file gets into Cura? 3D Builder, Netfabb, Paint 3D, Print 3D ? 3 of those come free with Win10.
     
  19. DBC

    DBC Senior Member

    If you can post the stl file, I can open it with my makerbot and see how it looks.
     
  20. DavidJ

    DavidJ Alibre Super User

    Just a thought - probably better to scale before generating STL file, rather than scale in the slicer.
     

Share This Page